九鼎创展论坛中文版English
登录 | 立即注册 设为首页收藏本站 切换到宽版
查看: 235|回复: 4

编译android5.1报错

[复制链接]
发表于 2018-8-22 15:53:28 | 显示全部楼层 |阅读模式
本帖最后由 seawind 于 2018-8-22 15:55 编辑

QQ图片20180822155420.png
回复

使用道具 举报

发表于 2018-8-22 16:06:36 | 显示全部楼层
系统是否市ubuntu14.04,是否按照手册android平台手册 3.1安装 android 源码依赖包中安装好了工具包,还有jdk市用的jdk1.7你吗?如果以上都满足的话,就查看源码包是否下载不完整。  你发的信息提示的有未定义的变量,你可以直接百度下这个错误。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-8-22 16:10:40 | 显示全部楼层
ubuntu14.04,   jdk:/usr/lib/jvm/java-7-openjdk-amd64   ,下载下来没有改动直接编译不过。你说的手册在哪里,我看到的手册是jdk1.6的
回复 支持 反对

使用道具 举报

发表于 2018-8-22 16:18:12 | 显示全部楼层
手册是根据安卓4.4写的,你安卓5.1需要jdk1.7,你对比下mk脚本里面的jdk和你下载的jdk是否一致。手册在网盘连接里面usermanual里面
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-8-22 17:46:08 | 显示全部楼层
lxz 发表于 2018-8-22 16:18
手册是根据安卓4.4写的,你安卓5.1需要jdk1.7,你对比下mk脚本里面的jdk和你下载的jdk是否一致。手册在网盘 ...

jdk我已经用1.7了,系统是新装的。源码也是完整下载直接编译。网上的方法也没有解决我的编译问题
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|深圳市九鼎创展科技官方论坛 ( 粤ICP备11028681号-2  

GMT+8, 2018-10-20 23:04 , Processed in 0.163336 second(s), 20 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表